Site Navigation

Your Account

Choose Language

iRobot needs a vacation!

Timur a new member created a an answer here: Why does my MacBook Pro retina display show only lines, flaw? iRobot marked it as SPAM! (which it's clearly not).

I reopened it, but it really needs to be a fresh question so I tried to alter it to a question got halfway and it won't let me save it! iRobot tells me it has been deleted. Lo and be hold, the answer is still marked as SPAM when I go back, I tried again same thing!

We've been seeing a few new posts lately that are being marked SPAM by iRobot. I've reopened a few as I had thought it was just a mistake.

I think iRobot has a code issue. As Timur has only posted this one entry.

Answered! View the answer I have this problem too

Is this a good question?

Score 4

Comments:

I keep telling you guys! We need to kill that robot! It will be the end for all of us!

by

Could be worse! They could take over ;-}

by

It's the same thing @danj! We need to be minding these mechanical devils!

by

Add a comment

3 Answers

Chosen Solution

Hey gang, in this case Timur posted the same text 39 times in attempting to get through, unfortunately iRobot sees this as spam because it's "sending the same message indiscriminately to (large numbers of recipients) on the Internet" (by definition: spam).

Now to be fair, the robot should be smarter about that initial post, but Timur added an answer to a post that hadn't been touched since May 2015. But really, iRobot was doing his job and was pretty rightfully suspicious, if robot "dumb".

I'm still cleaning up the posts, marking them valid and deleting the extra entries, in the mean time, iRobot left this post happily alone! https://www.ifixit.com/Answers/View/4186...

Obviously we want the system to be flawless, but the robot just isn't smart enough to see past certain triggers (yet!). So letting us know when he's gone awry is super helpful.

In the mean time, recommend that users start new questions rather than tacking on to very old questions.

Have them let us know after the first instance of spam by replying to the email.

Tell them not to keep posting, or iRobot's "This post is spam" decision will be upgraded to "This Users is a Spammer" and no posts will get through.

Was this answer helpful?

Score 3

Comments:

@sam - Sometimes iRobot gets a black eye when he (she) shouldn't ;-}

Thanks for picking this up. Hopefully we can catch up in SLO in Sept.

by

It's a very resilient bot, we appreciate the heads-up and it never hurts any feelings (or circuits) ;)

I'm crossing my fingers that iPhone launch won't come too early, that'd be the only thing to keep me away!

by

Add a comment

Hey Dan,

Thanks for bringing this to our attention. I'll have a sit down with iRobot and see if we can come to an understanding.

Was this answer helpful?

Score 2

Comments:

Hi @kaykay - Sam filled us in, give poor iRobot an extra helping of oil tonight ;-}

by

Add a comment

@sam @kaykay can you take a look at this profile https://www.ifixit.com/User/Activity/575... Not sure if it is a iRobot issue (I doubt that ;-) or if there is something else that has gone haywire

Was this answer helpful?

Score 1

Comments:

Hey! I got some emails from Lapo and I'm trying to get things sorted out! I'll report back in a short while =)

by

So I went ahead and reversed the spam markings, and I restored the rep level to the proper levels, that did mean eliminating some added rep, which I think was supposed to fix the loss of rep from the spam? So everything should be set, and Lapo is posting again freely.

by

@sam Excellent! Thank you Ma'am.

by

Add a comment

Add your answer

Dan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 0