Skip to main content
/

Site Navigation

Your Account

Choose Language

Are the E7440 batteries part of a bad batch?

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

This is an update to my previous post about this :(. I received this replacement on the 15th but did not have time to test it until today. Originally when I had this issue, I sent a support eMail out and the original was replaced. However, 2 cycles in and I lost 12% of the original capacity, and the runtime dropped from the 2 hour range, down to 1 hour.

In addition to a 12% FCC loss within 2 cycles, it arrived with ~79% charge and then dropped to 6% without warning the first time I used it. Didn't think too much of it but that was kind of a warning call to double check if there are any issues. Same as before; it takes my OEM 47Wh fine.

I’m beginning to suspect another faulty battery lot. Previous post: https://www.ifixit.com/Answers/View/6876...

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

This question was migrated from https://www.ifixit.com/Answers.

by

@danj just wondering why so no hard feelings. Any reason you migrated this?

Also here's the link to my previous testing: https://www.ifixit.com/Answers/View/6876...)

Yes, normally I advise against clone batteries like this but if any of you seen what ULV HSW machines are worth (even with the highest end CPU you can get like the i7-4600U which this has!) Dell wants $120-130 when the laptops are literally about as much even in a market where Zoom school is in session! They seem to have severe BDP on pricing batteries for their older systems more so then the newer ones (which tend to be worse when the pack expands, since it can destroy the plastic chassis).

by

@nick - This is the better place if you want an answer from iFixit on your iFixit battery.

by

@danj I see. Yeah, 2 cycles and -12% is suspiciously high.

by

Hey Nick,

Sorry to hear about the battery! I'll pass this along to our parts team and get some answers for you.

by

Add a comment

1 Answer

Hey Nick!

So, it doesn’t look like this issue is as widespread as it appears, and our parts team can’t find any evidence of a bad batch. If you’re still experiencing issues, let support@ifixit.com know. Sorry for the trouble!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Nick will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 0